아래의 목록 이외의 질문들에 대해서는 에이블맥스로 이메일 을 주시기 바랍니다.

 ADINA Installation
1. ADINA를 어떻게 설치 하나요?

2. 라이센스를 어떻게 설치 하나요?

3. Floating type의 license를 설치하여 사용시 “Error : Failed to obtain valid network license” 라는 메시지와 함께 AUI가 실행되지 않습니다.

ADINA-AUI

4. AUI 그래픽이 이상합니다.
5. 변형 그림(Deformed Plot)의 확대 계수(magnification factor)를 어떻게 바꿀 수 있나요?
6. 결과 표현에서 exponential operator를 쓰는 방법은?
7. ADINA AUI에서 Body의 디스플레이를 어떻게 향상시킵니까?
8. ADINA-AUI에서 다른 배경색을 선택하는 방법은?
9. AIDNA에서 다른 CAD(CATIA, Pro/E) 프로그램에서 모델링한 모델을 Import하는 방법은?

10. Parasolid file 을 Import 가 되지 않아요?

11. AUI 사용시 메모리 관련 에러 (error) 가 왜 발생되나요?

12. I-DEAS TRANSOR manual 은 어떻게 사용 하나요?

13. “Unable to retrieve Parasolid part : [파일명]” 라는 메시지가 뜨면서 형상을 볼 수가 없습니다.
14. ADINA에서 제공하는 Material 물성데이터가 있나요?
15. AUI안의 메뉴화면에서 항목이름이 완전하게 나오지 않습니다.
16. AIDNA에서 단위가 나와 있지 않습니다. AIDNA의 단위는 어떻게 되나요?
17. Volume 과 Body는 무엇이 다른가요?
18. Geometry Import시 단위를 변환은 어떻게 하나요?
19. 마우스 조작 시 마우스 커서가 십자가로 바뀌면서 아이콘을 선택할 수 없습니다.
20. Command file인*.in 파일을 열게 되면 아무것도 뜨지 않고 Message Window에 “Input Error”가 나타납니다.
21. 결과 파일이 상당히 크게 생성되어 불러올 때에도 오래 걸립니다. 결과 파일의 크기를 줄일 수 있는 방법은 없나요?
22. Online Manual의 Primer와 Verification 을 해보고자 합니다. 이 문제의 완성된 파일은 없나요?
23. ADINA의 Restart 기능은 어떻게 사용하나요?
24. Body의 일부 면이 Face Link가 되지 않습니다.
25. 파이프 내의 유체유동해석에서 포물선 형태의 유속조건을 주는 방법.
26. Undo 스텝이 너무 작아서 작업하기 불편한데요.
27. FSI해석(유체-구조 연성해석) 수행시 구조와 유체 mesh가 일치해야 하나요?
28. time function 과 time step 기능에 대해서 설명해주세요.

기타 질문

29. 인쇄된 매뉴얼 없나요?

30. 계산에 사용되는 메모리 설정

31. PC Windows 버전과 더불어 batch mode 에서 ADINA 프로그램을 어떻게 실행할 수 있습니까 ?

32. PC 윈도우 버전에서 User Supplied Subroutine 은 어떻게 사용할 수 있나요 ?

33. User Supplied Subroutine 을 위해 필요한 포트란 컴파일러 (Fortran compiler) 버전은 무엇입니까 ?

Solution error
34. CFD해석시 해석을 수행하자마자 “*** ERROR *** CODE ADF2037: Specific heat at constant pressure (Cp) 0.0000000E+00 is invalid.” 라는 메시지가 나타나면서 해석진행이 안됩니다.
35. CFD 해석 시 해석을 수행하자마자 “*** ERROR *** CODE ADF2075: -R option cannot be used for adaptive-mesh of sliding-mesh.” 라는 메시지가 나타나면서 해석 진행이 안됩니다.
36. 데이터 파일을 생성시 “Timefunction 1 does not span the range of solution times.” 라는 메시지가 뜨면서, 데이터 파일이 생성되지 않습니다.
37. Contact 조건이 포함된 구조 해석을 하는데 특별한 에러원인도 없이 해석이 안됩니다.
Post Processing
38. Post processing에서 band plot결과를 색깔로 나타내는 방식이 아닌 line contour방식으로 보고 싶습니다.
39. 해석 도중 결과를 확인하는 방법은 어떻게 되나요?
40. 해석결과의 특정 크기 범위만 나타내는 방법.
41. Poat-Processing에서 Scale Displacement 아이콘 의 기능은?
42. POR 파일의 용량이 너무 커서 잘 열리지 않는 경우 어떻게 해야 하나요?
43. ADINA에서 일부 선택된 노드에서 Streamline으로 나타내는 방법?
44. 특정 시간대의 해석 결과 동영상 제작법.
45. 3D 유체 모델에서 특정 위치의 노드를 찾기 어려운데 방법이 없나요?

 

 

1. ADINA 를 어떻게 설치 하나요?

자세한 사항은 아래 파일을 참조 하십시오 .

Installation Notes for Unix/Linux

Installation Notes for Windows

만약 노트북이나 인터넷 연결이 불안정할 경우 네트워크 연결을 하지 않고 설치하면 네트워크 연결에 상관 없이 ADINA 실행이 가능합니다 . 이 경우 SYSTEM ID 가 숫자로 표시됩니다 .

Return to FAQ list

 

2. 라이센스를 어떻게 설치 하나요?

-Node-lock license

Start > Programs > ADINA System 8.x > Install Node-Locked License

에서 node-lock license 를 설치합니다 .

-Floating license

Windows NT/2000/XP 는 ADINA floating license server 를 실행하십시오 .

Start > Programs > ADINA System x.x > Floating License > License Server 만약 상기한 폴더를 찾을 수 없다면 , %ADINAHOME%\Sentinel 디렉토리의 프로그램 loadls.exe 을 바로 실행함으로써 라이센스 서버를 시작할 수 있습니다 .

라이센스 패스워드 파일이나 라이센스 패스워드 파일을 위한 잘못된 이름이 아니라면 floating 라이센스 패스워드 파일이 확장자 없이 "lservrc" 라고 명명되어야 합니다 . 그것이 디렉토리 %ADINAHOME%\Sentinel(Windows) 또는 $ADINAHOME/slm (Unix/Linux) 에 놓여야 합니다 .

Return to FAQ list

 

3. Floating type의 license를 설치하여 사용시 “Error : Failed to obtain valid network license” 라는 메시지와 함께 AUI가 실행되지 않습니다.

floating license의 경우 네트워크로 라이선스 서버를 제공하여 외부에서 접속하여 사용하도록 되어있기 때문에 방화벽이나 백신 등 네트워크를 차단하는 프로그램이 있으면 위와 같은 에러메세지가 나타납니다. 그 외에도 몇가지 원인이 있으며, 다음과 같은 check list를 확인해보시면 대부분 해결됩니다.

Checklist for Windows Floating License Installation
1. Computer date is correct.
2. Computer (NETBIOS) name identical to host name.
3. All firewalls on all computers running ADINA allow traffic through UDP Port 5093
4. Windows File and Printer Sharing is turned on.
5. License server computer has fixed IP address, which is assigned to its host name.
6. LSFORCEHOST System Environmental Variable set to IP address of license server computer.
7. ADINALCTYPE System Environmental Variable set to 'EDUCATIONAL' for educational floating licenses, or 'NETWORK' for industrial floating licenses.

After making any changes, log off the Windows account and log in again; alternatively, reboot the computer.

Tests to pass
1. WLMAdmin.exe (or lsmon.exe) shows the presence of the license being loaded and available.
2. ping <client host name> run from the server computer resolves and completes successfully.
3. ping <server host name> run from the client computer resolves and completes successfully.
4. ping %lsforcehost% from a Windows client computer resolves and completes successfully.
5. Of course, run the AUI and check that it works.

4. AUI 그래픽이 이상합니다 .

몇몇의 PC 그래픽 카드는 OpenGL 그래픽 시스템 아래에서 올바르게 작동하지 않을 수 있습니다 . 시스템을 Windows GDI 그래픽으로 전환하십시오 . ADINA-AUI 메뉴에서 그래픽 시스템을 클릭하여 Windows GDI 그래픽 시스템을 선택하십시오 .

Return to FAQ list

 

5. 변형 그림 (Deformed Plot) 의 확대 계수 (magnification factor) 를 어떻게 바꿀 수 있나요?

다음과 같은 과정을 통하여 확대계수를 수정할 수 있습니다 .

1. Modify Mesh plot 아이콘을 클릭한다 .

2. Model Depiction 을 선택한다 .

3. Displacement Display Options 에서 사용자가 원하는 확대 계수를 설정 할 수 있다 .

Return to FAQ list

 

6. 결과 표현에서 exponential operator 를 쓰는 방법은?

ADINA 플롯에서 인터페이스 메뉴를 이용하여 결과 변수를 정의할 수 있습니다 .

Definitions > Variable > Resultant...

exponential operator 를 표현하기 위해 (**) 를 이용합니다 .

예 , <STRESS-YY>**2

Return to FAQ list

 

7. ADINA AUI 에서 Body 의 디스플레이를 어떻게 향상시킵니까?

일반적인 경우 , ADINA AUI 에서 Body 의 가장자리 ( 특히 곡선 ) 가 매끄럽게 표시되지 않습니다 . 단지 Body 의 형상 특징만 나타내고 , 형상을 정확하게 나타내지 못하는 경우가 있습니다 . 이 경우 디스플레이 성능을 향상시키기 위해 다음과 같이 실행하면 Body 의 가장자리를 매끄럽게 표시할 수 있습니다 .

1) Modify Mesh Plot 아이콘 클릭

2) Line Depiction button 클릭

3) ADINA-M Chord Angle 0.4 에서 0.1 로 바꾸고 "ok" 를 클릭

4) Surface Depiction button 클릭

5) 다시 ADINA-M Chord Angle 0.4 에서 0.1 로 바꾸고 "ok" 를 클릭

6) Modify Mesh Plot dialog box 를 "ok" 를 클릭

Return to FAQ list

 

8 . ADINA-AUI 에서 다른 배경색을 선택하는 방법은?

ADINA-AUI 는 많은 배경색을 지원합니다 . 메뉴에서 "Edit-Background Color- 원하는 색" 으로 선택해 주시면 됩니다.

Return to FAQ list

 

9. AIDNA 에서 다른 CAD(CATIA, Pro/E) 프로그램에서 모델링한 모델을 Import 하는 방법은?

CAD 프로그램으로 생성된 모델을 Import 하는 방법은 두 가지가 있습니다 . iges file (CATIA) 로 EXPORT 하는 방법과 (CATIA) 과 Parasolid file(*.x_t)(Pro-E) 로 EXPORT 하여 IMPORT 하는 방법이 있습니다 . 단 어셈블리일 경우에는 Import 가 잘 되지 않으니 Part 로 Export 한 후에 Import 하시기 바랍니다 . 또한 iges file 로 import 할 경우 , import to ADINA-M 체크 해주시고 아래 "sew ADUAN-M Sheet Body" 를 체크 해 주셔야 합니다 . parasolid file import 는 메뉴바에서 "ADINA-M - Import parasolid file" 로 하시면 됩니다.

Return to FAQ list

 

10. Parasolid file 을 Import 가 되지 않아요?

parasolid file 을 Import 하실 때 parasolid 파일이 저장되어 있는 폴더의 경로에 한글이 포함되어 있으면 parasolid 파일을 제대로 import 할 수 없습니다 . 파일이 저장되어 있는 폴더의 경로를 확인하여 한글이 포함되어 있을 경우 영어나 숫자로 변경하신 후 import 하시기 바랍니다.

Return to FAQ list

 

11. AUI 사용시 메모리 관련 에러 (error) 가 왜 발생되나요?

AUI 는 기본적으로 16M 의 메모리를 사용하도록 설정 되어 있습니다 . 큰 용량의 격자 (mesh) 를 생성 하거나 큰 용량의 (*.por) 파일을 open 할 경우 “Edit>Memory Usage” 에서 AUI 사용 메모리를 많이 설정해주면 작업 속도를 향상 시킬 수 있다 . 최대 500M 의 메모리를 할당하여 사용하실 수 있습니다.

Return to FAQ list

 

12. I-DEAS TRANSOR manual 은 어떻게 사용 하나요?

ADINA 7.4 부터 TRANSOR 와 I-DEAS 사용자 매뉴얼이 HTML 포맷으로 제공됩니다 . ADINA CD ROM 으로부터 I-DEAS TRANSOR 을 설치하면 HTML 파일이 하드 디스크로 복사되어질 것입니다 . HTML 파일은 <ADINA home directory>/html/transor 에 있습니다.

I-DEAS 에서 응용 장치를 통해 매뉴얼을 볼 수도 있다.

Unix 와 PC 둘 다 창을 위해 , 브라우저와 더불어 파일 start.htm 로 매뉴얼에 접근 할 수 있습니다.

 

Return to FAQ list

 

13. “Unable to retrieve Parasolid part : [파일명]” 라는 메시지가 뜨면서 형상을 볼수가 없습니다.

이런 메시지는 형상모델링을 ADINA-M에서 작업한 경우 함께 저장되는 Parasolid(*.x_t)파일을 불러들여오지 못하는 경우에 발생합니다. 주로 함께 저장된 parasolid 파일을 제외하고 IDB파일만을 다른 폴더에 옮겨서 사용할 때 발생하며, 저장된 경로나 파일명에 한글이나 uni-code문자가 들어있는 경우에 idb파일은 열리나 parasolid파일이 함께 열리지 못하여 발생하기도 합니다.

 

14. ADINA에서 제공하는 Material 물성데이터가 있나요?

ADINA에서는 따로 Material property data를 제공하고 있지 않습니다. 같은 steel의 물성이라고 하더라도 elastic model을 사용하는 multi-linear 또는 bilinear plastic model을 쓰느냐에 따라서 필요한 정보들이 달라지기 때문이며, 대신 한번 사용했던 물성을 저장하여 자기만의 Material Data Base(MDB)를 구축할 수 있습니다. 사용방법은 “기술정보”란에 기재되어 있습니다.

 

15. AUI안의 메뉴화면에서 항목이름이 완전하게 나오지 않습니다.

windows 32bit 버전에서 남아있는 버그로써 windows 64bit 또는 Linux버전에서는 정상적으로 나타나며, online manual의 AUI Commands 를 통해 확인하시면 설명과 함께 정확한 명칭을 확인하실 수 있습니다.

 

16. AIDNA에서 단위가 나와 있지 않습니다. AIDNA의 단위는 어떻게 되나요?

AIDNA AUI 에서는 따로 단위를 나타내지 않고 있습니다. 보편적으로 형상에서 정의 되는 단위에 있어서 물성의 단위와 각 조건들의 단위가 결정 되게 됩니다. 아래의 그림은 단위 길이에 따른 단위 구성 표 입니다.


17. Volume 과 Body는 무엇이 다른가요?

Volume 과 Body는 ADINA AUI를 통해 내부적으로 생성할 수 있는 Geometry의 종류가 되겠습니다. Volume의 경우 Line 과 Surface 로 이루어져 있으며, 육면체 형태까지 생성할 수 있습니다. Body의 경우 Edge와 Face 로 이루어져 있으며, 복잡한 형태의 형상을 정의 할 수 있습니다. 이러한 특징으로써 Body는 다른 Body와의 Boolean Operator 기능을 이용하여 더하고 빼면서 형상을 정의할 수 있습니다. 마지막으로 Volume의 경우 정렬격자(Mapped Mesh)형성에 유리하며, Body의 경우 복잡한 모델에서의 격자 생성이 유리하겠습니다.

 

18. Geometry Import시 단위를 변환은 어떻게 하나요?

AIDNA에서 Geometry Import 방법은 두 가지가 있습니다. Parasolid 형상과 IGES 형상입니다. Parasolid 형상의 경우 Menu에서 AIDNA ? M 항목의 Import Parasolid Model 를 사용하게 되며, Import 창의 Unit이라는 별도의 단위 변환을 할 수 있도록 되어 있습니다.
Old는 이전에 가지고 있던 단위이며, New는 새로 적용 시킬 단위가 되겠습니다. IGES의 경우, Menu의 File 항목에서 Import IGES 를 사용하며, Scale Down Factor를 이용하여 단위를 조정할 수 있습니다. 이전의 mm 단위에서 m 단위로 Import하고자 한다면, Down Factor 에는 mm와 m 의 비율인 1000을 입력하면 되겠습니다.

 

19. 마우스 조작 시 마우스 커서가 십자가로 바뀌면서 아이콘을 선택할 수 없습니다.

ADINA에서 하중 조건 및 기타 선택 창을 보면 녹색의 창이 보이게 됩니다. 이 녹색 창은 조건 적용 부분 등을 Text로 입력이 가능하며, 더블 클릭 시 Pick 모드로 전환되어 화면 상에서 선택할 수 있습니다. 이 때에 Pick 모드로 전환하게 되면, 마우스 커서가 십자가 모양으로 바뀌게 되면서, 다른 작업을 할 수 없도록 됩니다. 따라서 이 때에는 ESC 버튼을 이용하여 Pick 모드를 해제해 주시면, 다른 기능을 수행할 수 있습니다.

 

20. Command file인 *.in 파일을 열게 되면 아무것도 뜨지 않고 Message Window에 “Input Error”가 나타납니다.

Parasolid 형상을 사용했다면 저장 후 *.X_T파일이 생성되게 됩니다. 이 때 *.in 파일로 저장하신 파일을 열어보시면, Geometry의 경로 설정을 해주셔야 하는 부분이 있습니다. LOADSOLID PARTFILE='C:\Structure.x_t' 이 부분을 *.X_T파일이 저장 된 폴더로 경로를 변경 해 주시면 파일을 올바르게 불러올 수 있습니다.

 

21. 결과 파일이 상당히 크게 생성되어 불러올 때에도 오래 걸립니다. 결과 파일의 크기를 줄일 수 있는 방법은 없나요?

일반적으로 결과 파일의 경우 각 Step 마다 저장 되게 됩니다. 하지만 이 저장 되는 Step을 일정간격 혹은 사용자가 정의한 Step 간격으로 저장 할 수 있겠습니다. Menu에서
Control ? Porthole(.por) ? Time Steps(Nodal Result)/(Element Result) 창에서 Block은 적용 번호(임의의 번호), initial Time Step은 시작 Step, Final Time Step은 종료 Step, Increment는 Step의 증가분이 되겠습니다. 예를 들면 Block 번호 1 번에 1 Step 부터 100 Step까지 10Step 간격으로 저장을 하고자 한다면 (1) (1) (100) (10) 로 입력해주시면 되겠습니다. 이 때에 Copy Time Step Blocks to Element Result를 Overwrite로 선택하여 Nodal result와 Element result의 저장 Step 을 동일하게 설정 할 수 있도록 합니다.

 

22. Online Manual의 Primer와 Verification 을 해보고자 합니다. 이 문제의 완성된 파일은 없나요?

Primer 및 Verification 문제의 경우, ADINA 설치 폴더에 포함 되어있습니다. 아래의 경로를 이용하여 찾을 수 있습니다. ‘ADINA의 설치 폴더 ? Samples’ Samples 폴더 안에는 ‘a’, ‘b’, ‘f’, ‘t’, ‘primer’ 폴더가 있으며, ‘a’, ‘b’, ‘f’, ‘t’ 는 Verification 문제의 in 파일 폴더가 되겠습니다. ‘a’ 는 선형 구조해석, ‘b’ 는 비선형 구조해석, ‘f’는 유체해석, ‘t’는 열 해석 폴더가 되겠습니다. ‘primer’ 폴더 안에는 모든 문제에 대한 in파일과 형상 파일, dat 파일이 포함되어 있습니다.

 

23. ADINA의 Restart 기능은 어떻게 사용하나요?

ADINA의 Restart 기능의 설정은 Solution Process에서 설정하게 됩니다. Solution Process 의 Solution Restart Time 입력 창에 이전의 해석이 된 시간을 입력해 주시고, Restart Analysis 를 Check 해 주시면 되겠습니다. 또한 Restart 시에는 Time Step에서의 해석 시간이 Restart 시작 시간에서부터 적용 되기 때문에 Time Function 의 시간이 총 해석 시간 보다 부족하지 않게 설정해 주셔야 하겠습니다. 또한 이전의 해석 파일(dat) 이름과는 별도로 구분해주셔야 하며, Solver 구동 시 Restart에 필요한 이전 해석 파일의 Restart file(res)을 요구하게 됩니다. FSI 해석의 Restart 시 유체와 구조 파일의 선택 순서에 따라서 Restart 파일을 요구하는 순서가 변경 될 수 있습니다. 따라서 유체와 구조 파일의 이름을 확인하여 선택해 주시면 됩니다.

 

24. Body의 일부 면이 Face Link가 되지 않습니다.

Face Link는 node를 서로 연결해 주는 역할을 하므로 Face Link 가 되어 있지 않으면 해석에 오류가 발생하게 됩니다. 일반적으로 ‘Create for All Faces/Surfaces’ 을 선택해 Body 가 연결되는 모든 면을 링크시켜 줍니다. 이 때 일부의 면에서 Face Link 가 설정되지 않는다면, 두 접촉면에서 면이 서로 일치하지 않기 때문입니다. 예를 들어 Body #1의 하나의 면에 Body #2의 두 개의 면이 존재하는 경우 서로 면이 일치하지 않으므로 링크가 되지 않습니다. 이러한 경우 Boolean Operator 에서 Subtract 를 통해 Body #1에서 면의 수가 더 많은Body #2 를 빼주고 아래와 같이 체크해 줍니다.

 

25. 파이프 내의 유체유동해석에서 포물선 형태의 유속조건을 주는 방법.

FE 모델에서는 실제 전체 길이의 파이프를 모델링할 수 없으므로 일부 잘라진 파이프의 Inlet 부분은 실제 파이프 내의 유속분포를 설정해 줄 필요가 있습니다.
Geometry의 Spatial Function에서 이러한 설정이 가능하며, 2D 모델의 경우 아래와 같이 Quadratic 에서 간단하게 설정할 수 있으며 여기에 입력되는 숫자는 하중조건에서 정의한 Velocity 의 크기와 곱한 값이 최종 속도 분포로 설정됩니다.

3D 모델의 원형 파이프 모델인 경우는 아래의 그림과 같이 입력해 줍니다.

대칭적인 포물선 모양이 아닌 경우 Type을 Tabular 로 선택해 함수로 입력해 줄 수 있습니다.

26. Undo 스텝이 너무 작아서 작업하기 불편한데요.

ADINA에서 설정되어 있는 Undo 의 스텝 수는 ‘5’입니다. 마우스로 모델을 움직이거나 축소/확대하는 것도 스텝에 포함되기 때문에 무엇인가를 설정하고 나서 모델을 움직이다 보면 undo 가 설정 전까지 되지 않아 불편한 경우가 있습니다.
이런 경우 아래의 경로를 통해 Undo Level 의 숫자를 큰 숫자로 입력해 줍니다.
일반적으로 20~50으로 입력하여 사용하시면 충분할 것으로 생각됩니다.

Edit → Environment Settings

27. FSI해석(유체-구조 연성해석) 수행시 구조와 유체 mesh가 일치해야 하나요?

일치하지 않아도 됩니다. 다음 그림을 참조하여 설명드리자면 왼쪽이 유체 영역, 오른쪽이 구조영역일 때 solid node 2에서의 fluid stress는 fluid node 2와 3의 fluid stress가 보간되어 적용됩니다. 즉, FSI interface에서 데이터를 서로 보간하여 사용하기 때문에 구조와 유체영역의 mesh가 일치하지 않아도 해석이 가능합니다.


단, 유체node에서 구조 FSI경계면까지의 상대거리가 위와 같을 시에는 Error또는 Warning이 발생하게 됩니다.
이를 피하기 위해서는

- 모델을 단순화(불필요한 세부형상 제거)
- 경계형상에 fine mesh생성
- 날카로운(Sharp) 형상에서는 유체와 구조의 mesh를 유사하게 생성
- 구조 영역을 2차 요소로 적용

하는 등의 방법이 있습니다.

 

28. time function 과 time step 기능에 대해서 설명해주세요.

time function은 dynamic 과 transient 시간과 연관되는 해석에서 시점에 따른 Loading 또는 boundary의 크기를 정해주는 기능을 합니다. 또한 dynamic 과 transient 해석에서 해석 하고자 하는 시간을 설정 합니다.

Time step은 Time function에서 설정한 시간을 원하는 개수(Number of Step)로 나누어 주는 기능을 합니다. Constant Magnitude에서 나누고자 하는 시간의 크기를 설정합니다.

Time function에서 설정한 시간 = Number of Step x Constant Magnitude
Ex) 10s = 100 steps x 0.1s

29. 인쇄된 매뉴얼 없나요?

ADINA 시스템 8.1 부터 PDF 형식으로 메뉴얼을 제공하고 있습니다.

ADINA 매뉴얼은 Help>Online Manuals 에서 확인 하실 수 있습니다.

Return to FAQ list

 

30. 계산에 사용되는 메모리 설정

ADINA 는 계산에 사용되는 메모리를 설정하여 주실 수 있습니다 . 메모리의 용량이 크면 계산속도가 빨라지겠죠 . 사용자가 자동으로 설정하면 물리적 메모리의 약 85% 를 설정하여 계산에 사용됩니다 . 그러나 사용자 임의로 설정하여 주실수도 있습니다 . 메모리의 사용량을 늘리시려면 기본적인 windows 테마를 Classic 으로 변경하면 조금이라도 늘리실 수 있습니다.

Return to FAQ list

 

31. PC Windows 버전과 더불어 batch mode 에서 ADINA 프로그램을 어떻게 실행할 수 있습니까?

 

PC Windows 에서 ADINA 프로그램이 대화모드로 구동 되어 진다 . 그러나 사용자의 입력 없이 여러 연속적인 작업을 수행하기 위해 batch mode 안에 프로그램들이 사용되어진다 . ADINA-AUI 에서 일광 명령은

...\aui.exe -b -m <MTOT>[b|w] <file>.[in|plo]

Aui.exe 가 위치된 완벽한 경로를 참조한다 . <MTOT> 값은 bytes(b) 또는 words(w) 로 표현 되어진다 . 1word=4bytes

20 메가바이트를 할당하여 batch mode 에서 prob02.in 입력하여 구동시키기 위해 아래와 같이 입력하여 계산을 수행한다 .( 가정 aui.exe 는 c:\adina\aui 에 설치되었다 ),

c:\adina\aui\aui.exe -b -m 20mb prob02.in

<MTOT> 값의 단위는 M(Mega), K(Kilo), G(Giga) 사용합니다.

Return to FAQ list

 

32. PC 윈도우 버전에서 User Supplied Subroutine 은 어떻게 사용할 수 있나요?

 

ADINA 7.5 버전부터 , 프로그램 모듈을 위한 user-supplied subroutine 소스 파일이 설치 됩니다 . 만약 ADINA 의 이전의 버전을 이용하고 있다면 , user-supplied subroutine 소스 파일을 입력하는 방법은 아래의 섹션을 참고 하십시오 . user-supplied subroutines 이 (*.dll) 파일로 만들어 진다 (dynamic link library). 디지털 포트란 6.0 컴파일러를 이용하면서 텍스트 에디터와 함께 새로운 (*.dll) 을 편집한 text 와 user-supplied subroutines 위한 포트란 소스 파일을 부분 수정할 수 있습니다 . user-supplied subroutines 을 편집할 makefile 이 제공됩니다 . 편집하기 위해 , DOS window 창을 열고 makefile 와 포트란 파일을 가지고 있는 디렉토리로 이동 합니다 . ADINA 프로그램 모듈을 위한 user-supplied subroutines 을 수정하여 가정 할 수 있습니다.

cd "%ADINAHOME%\adina"

Fortran file 을 수정한 후 두 개의 명령을 수행 합니다.

...\DF98\bin\dfvars 
nmake

첫번째 명령은 적절한 포트란 환경을 만들고 , 두 번째 명령은 부분적으로 수정된 서브루틴을 편집하고 새로운 (*.dll) 파일을 만듭니다 . 편집이 성공적이라면 , 솔루션 프로그램을 실행할 때 새로운 (*.dll) 을 사용 할 수 있습니다.

 

33. User Supplied Subroutine 을 위해 필요한 포트란 컴파일러 (Fortran compiler) 버전은 무엇입니까?

ADINA 에 ( 서 ) 사용자 공급한 루틴의 주문형을 위한 포트란 컴파일러

Platform

Command

Fortran Compiler

HP-UX 11
(PA-RISC 2)

f90 +version

HP F90 v2.8.5

HP-UX 11.22 (Itanium)

f90 +version

HP F90 v2.8.1

IBM AIX 5.1

lslpp -h xlfcmp

XL FORTRAN V 8.1.0.0

Linux x86

ifort ?V

Intel(R) Fortran Compiler for 32-bit applications, Version 8.1, Build 20040803Z

Linux IA-64
(Itanium)

efc ?V

Intel(R) Fortran Itanium(R) Compiler for Itanium(R)-based applications, Version 7.1, Build 20040708

Linux x86_64 (Opteron)

ifort -V

Intel(R) Fortran for EM64T-based applications, Version 8.1, Build 20041123

SGI IRIX 6.5

f90 ?version

MIPSpro Compilers, Version 7.3.1.3m

SGI Altix

ifort -V

Intel(R) Fortran Itanium(R) Compiler for Itanium(R)-based applications, Version 9.0, Build 20050912

Solaris 8
(64-bit version)

f95 ?V

Sun WorkShop 6 update 2 Fortran 95 6.2, 2001/05/15

PC Windows

-

Compaq Visual Fortran 6.6

 

Return to FAQ list

 

34. CFD해석시 해석을 수행하자마자 “*** ERROR *** CODE ADF2037: Specific heat at constant pressure (Cp) 0.0000000E+00 is invalid.” 라는 메시지가 나타나면서 해석진행이 안됩니다.

ADINA-CFD모듈에서는 열전달을 고려하도록 기본 환경설정이 설정되어 있으므로 일반적으로 CFD해석시 열전달을 고려할 것인지를 먼저 확인하셔야 합니다. 위의 메시지는 열전달을 고려하도록 설정하였을 때 열과 관련된 물성치(비열)가 입력되지 않아 나타나는 에러메세지로 메뉴 model ? Flow assumption에서 “include heat transfer” 옵션을 체크해제하시면 됩니다.

 

35. CFD 해석 시 해석을 수행하자마자 “*** ERROR *** CODE ADF2075: -R option cannot be used for adaptive-mesh of sliding-mesh.” 라는 메시지가 나타나면서 해석 진행이 안됩니다.

ADINA-CFD모듈에서 데이터 파일 저장 및 Solver 구동 시에는 Adaptive mesh와 Sliding Mesh를 사용했을 경우 Automatic Memory Allocation(자동 메모리 할당) 메뉴를 사용 할 수 없습니다. 따라서 Automatic Memory Allocation 항목을 해제해 주시고 Maximum Memory for Solution 을 0으로 입력 후, Memory for Storing Model Data 항목에 할당 메모리는 입력하여 해석을 수행하면 되겠습니다.

Ex) Maximum Memory for Solution: 0 Mbytes
Memory for Storing Model Data: 500Mbytes

 

36. 데이터 파일을 생성시 “Timefunction 1 does not span the range of solution times.” 라는 메시지가 뜨면서, 데이터 파일이 생성되지 않습니다.

이런 메시지는 Timefunction 1 에서 정의한 시간보다 Time step에서 정의한 총 해석시간이 더 크기 때문에 나타나는 현상 입니다. 예를 들어 100N의 하중을 0초에서 1초 동안 Timefunction에 정의 하고, Time Step을 0.1 초 간격으로 20 step 으로 설정 하였다면, 1초까지 100N의 하중은 정의 되고 해석은 총 2초까지 수행하고자 하는 것입니다. 따라서 하중 조건이 미치지 않고, 계산이 진행되는 1초와 2초 사이는 무의미 하게 되는 것입니다. 따라서 반드시 Timefucntion 에서 정의한 시간은 Time step에서 정의한 총 시간 보다는 같거나 커야 합니다.

 

37. Contact 조건이 포함된 구조 해석을 하는데 특별한 에러원인도 없이 해석이 안됩니다.

구조해석에서 해석이 안 되는 흔한 원인은 다음과 같습니다:
- Geometry 단위와 물성 또는 하중 조건에서 사용한 단위가 서로 다를 때.
- Fixity 조건이 설정되지 않은 경우, 이런 경우엔 매 time step 마다 ‘Model may be unstable’ 라는 메시지가 나타납니다.)
- 하나의 Contact Pair 에서 Contact 벡터 방향이 동일하게 설정된 경우.

세 번째의 경우는 Contact Surface 창에서 아래의 그림과 같이 일반적으로 ‘Automatically’ 로 설정할 때 발생할 수 있습니다.


디스플레이에서 나타난 모델을 ‘Show Contact Surface’와 ‘Show Segment Normals’ 아이콘으로 접촉조건 상태를 확인한 후 같은 방향으로 설정된 Contact Surface 중 하나를 벡터 방향이 바뀌도록 설정합니다. 이를 위해 위의 그림에서 ‘Automatically’ 대신 ‘from Table input’으로 변경한 후 ‘Follow Geometry’와 ‘Opposite to Geometry’를 서로 바꾸어 설정합니다.
Contact 면에서의 벡터 방향은 아래의 그림과 같이 서로 다른 방향을 가리키도록 설정해야 합니다.

여기에서 Geometry의 의미는 위의 그림 오른쪽에 나타낸 것처럼 Line/Edge 의 화살표 방향을 의미합니다.

38. Post processing에서 band plot결과를 색깔로 나타내는 방식이 아닌 line contour방식으로 보고 싶습니다.

먼저 보고자 하는 band plot을 생성합니다.(stress, pressure, displacement 등) 그 후 메뉴 display band plot ? modify 를 실행시킨 후 band rendering 버튼을 클릭하여 type을 ‘solid area fills’에서 ‘line contour’로 변경하면 됩니다.
추가로, band plot modify메뉴에서 band table로 들어가 number of color의 개수를 0에서 원하는 숫자로 변경하시면 색의 개수를 설정하실 수 있으며, maximum value나 minimum value등을 설정하실 수 있습니다.


39. 해석 도중 결과를 확인하는 방법은 어떻게 되나요?

32Bit의 경우 해석 파일을 바로 확인하는 방법은 결과 파일을 복사하는 것입니다. Post-Processing의 열기 창에서 현재 진행 되고 있는 결과 파일을 볼 수 있으며, 이 파일을 복사하여 다른 이름으로 복사 후 열기를 통해 확인 하시면 되겠습니다. 64Bit의 경우는 현재 진행 중인 파일을 바로 선택하여 결과를 확인할 수 있습니다.

 

40. 해석결과의 특정 크기 범위만 나타내는 방법.

위의 설정은 Band Plot 을 나타내었을 때 해석결과에 대한 최대값과 최소값의 영역이 너무 커 확인하고자 하는 부분의 색이 잘 구분이 안 되는 경우 사용하게 됩니다.
‘Create Band Plot’ 창에서 Band Plot 옆에 있는 탭을 클릭하시고 ‘Band Attributes’의 Band Table 의 탭을 클릭합니다. 그런 후 Automatic 으로 지정되어 있는 Value Range의 Maximum과 Minimum 을 클릭하여 특정 크기를 정의해 줍니다.
Color Attributes의 ‘Number of’의 입력창은 ‘0’ 큰 숫자를 입력하는 경우 색의 영역을 나누어 주어 보다 부드러운 Band Plot 을 나타낼 수 있습니다.
위의 경로는 ‘Modify Band Plot’ 에서 Band Table 로 들어가는 것과 같습니다.

 

41. Poat-Processing에서 Scale Displacement 아이콘 의 기능은?

10% 표시로 나타난 이 아이콘은 구조물의 변형이나 변위의 차이가 육안으로 확인하기 어려울 때 주고 많이 사용합니다. 스케일은 ADINA에서 자동으로 설정하기 때문에 작은 변위를 확장해서 나타내 주거나 반대로 너무 큰 변위 결과를 작게 나타내 주기도 합니다. 자동으로 설정된 Factor의 크기는 디스플레이에 ‘DISP MAG’라는 표시와 함께 숫자로 나타내 줍니다. 자동 설정된 이 Factor는 유저에 의해 직접 설정될 수 있습니다:
Display → Geometry/Mesh Plot → Modify
을 선택하신 후 아래의 창이 나타나면 ‘Model Depiction’을 클릭해 줍니다.


다음 아래의 창에서 붉은 박스로 나타낸 부분에 Factor를 입력해 줍니다.

42. POR 파일의 용량이 너무 커서 잘 열리지 않는 경우 어떻게 해야 하나요?

POR 파일의 용량이 너무 크다 보면 결과파일을 여는데 많은 소요시간을 요구합니다. 설정된 Time Step을 모두 저장할 필요가 없다면 특정 Time Step에 대한 해석결과만 저장하여 POR 파일의 용량을 줄일 수 있습니다.
예를 들어 Time Step 에서 총 500 스텝을 설정한 경우 아래의 그림과 같이 매 10번째 스텝마다 해를 저장할 수 있습니다.
‘Overwrite Any...’은 Element에 대한 결과 저장 방법도 동일하게 설정할 때 선택해 줍니다.

Control → Porthole(.por) → Time Steps (Nodal Results)


첫 번째 스텝은 자동으로 저장이 되며 그 이후 10번째 스텝마다 저장되어 아래와 같은 Step Number 에서 저장됩니다:
1. step, 11 step, 21 step

 

43. ADINA에서 일부 선택된 노드에서 Streamline으로 나타내는 방법?

Streamline을 나타내 유체의 유동상태를 확인할 수 있습니다.
여기에서는 예로 노드에 최초 지점을 설정하는 법을 알려드립니다.
Display → Particle Trace Plot → Create
로 들어가 Trace Rake 옆에 있는 탭을 클릭합니다.
녹색테이블에 노드 번호를 입력하시거나 더블 클릭하여 마우스로 직접 선택해 줍니다.
또는 Type을 Coordinates로 선택하여 좌표를 입력해 줄 수 있습니다.

다음 Trace Plot에서 Trace 옆에 있는 탭을 클릭해 아래와 같이 설정해 줍니다.


Current Particle...’와 ‘Particle Time Step’의 크기는 유저가 변경하여 확인할 수 있습니다.
마지막으로 아래의 아이콘을 클릭하여 스텝 별 Streamline의 경로를 확인합니다.

44. 특정 시간대의 해석 결과 동영상 제작법.

Display → Movie Shoot → Load Step
에서 아래 그림과 같은 창에서 ‘Start’ 와 ‘End’ 입력칸에 지정하고자 하는 시간을 입력한 후 ‘OK’를 클릭해 줍니다.
지정된 시간대에서 슬라이드 저장이 완료되는 것은 마우스가 모래시계 모양에서 다시 화살표 모양으로 나타나는 것으로 알 수 있으며, ‘Save AVI’ 아이콘을 클릭해 동영상으로 저장해 줍니다.

 

45. 3D 유체 모델에서 특정 위치의 노드를 찾기 어려운데 방법이 없나요?

Cut Surface 를 사용해 찾을 수 있습니다. 단 Default 상태에서 특정 위치의 Cut Surface를 나타내 보면 절점이 안 나타나 있는데요, 이는 절점이 정확이 Cut Surface에 위치해 있지 않기 때문입니다.
이런 경우 뒷 부분의 노드들을 모두 나타나기 위해 아래와 같이 설정하신 후 ‘Shading’ 아이콘을 클릭하면 Cut Surface 에 정확히 위치하지 않은 절점들을 확인할 수 있습니다.
반드시 정확한 위치의 절점에서 결과값을 확인하고자 하는 경우엔 그 위치에 면을 만들어 주어야 합니다.